summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/nginx/euer.mon.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-17 00:42:16 +0200
committermakefu <github@syntax-fehler.de>2018-09-17 00:44:21 +0200
commit9adb8c9825de13b1a911863fd70d733029023042 (patch)
tree0b952afa758552a39ab557d1c80934e08c50f079 /makefu/2configs/nginx/euer.mon.nix
parentb54f309eb9ed60a1fe9120a07dc9afda6ee20666 (diff)
ma euer.mon.krebsco.de: proxy to wbob
Diffstat (limited to 'makefu/2configs/nginx/euer.mon.nix')
-rw-r--r--makefu/2configs/nginx/euer.mon.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/makefu/2configs/nginx/euer.mon.nix b/makefu/2configs/nginx/euer.mon.nix
index c5a7e68a..765fef53 100644
--- a/makefu/2configs/nginx/euer.mon.nix
+++ b/makefu/2configs/nginx/euer.mon.nix
@@ -10,7 +10,12 @@ let
in {
services.nginx = {
enable = mkDefault true;
- virtualHosts."mon.euer.krebsco.de" = {
+ virtualHosts."mon.euer.krebsco.de" = let
+ # flesh_wrap
+ authFile = pkgs.writeText "influx.conf" ''
+ user:$apr1$ZG9oQCum$FhtIe/cl3jf8Sa4zq/BWd1
+ '';
+ in {
forceSSL = true;
enableACME = true;
locations."/" = {
@@ -21,6 +26,17 @@ in {
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
'';
};
+ locations."/influxdb/" = {
+ proxyPass = "http://wbob.r:8086/";
+ extraConfig = ''
+ auth_basic "Needs Autherization to visit";
+ auth_basic_user_file ${authFile};
+ proxy_http_version 1.1;
+ proxy_set_header Host $http_host;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_redirect off;
+ '';
+ };
};
};
}