summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/main-laptop.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-23 02:48:35 +0200
committermakefu <github@syntax-fehler.de>2015-08-23 02:48:35 +0200
commit7a1e2f83b242b6779e1590082fbe93a8ed429611 (patch)
tree8bfae8a9a2583250d92efbe66d5813b80d73be8e /makefu/2configs/main-laptop.nix
parentf666c217906382bd63dddc83f7f822c1798c3df7 (diff)
makefu: cleanup,refactoring after transfer
Diffstat (limited to 'makefu/2configs/main-laptop.nix')
-rw-r--r--makefu/2configs/main-laptop.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/makefu/2configs/main-laptop.nix b/makefu/2configs/main-laptop.nix
new file mode 100644
index 00000000..8d2c8213
--- /dev/null
+++ b/makefu/2configs/main-laptop.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+# stuff for the main laptop
+# this is pretty much nice-to-have and does
+# not fit into base-gui
+
+with lib;
+{
+ imports = [ ./base-gui.nix ];
+ environment.systemPackages = with pkgs;[
+ vlc
+ firefox
+ chromium
+ keepassx
+ ];
+
+ services.redshift = {
+ enable = true;
+ latitude = "48.7";
+ longitude = "9.1";
+ };
+
+}