summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/tp-x2x0.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
committermakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
commit37744f0016b77af41e8f57bc6da32b15f5ac50fd (patch)
treef51174cd0c20364eb9f4b03342dbaed7250a7729 /makefu/2configs/hw/tp-x2x0.nix
parentf911d43005d043ca360837eb8b3c2c2fe30bc962 (diff)
makefu: sort 2configs
Diffstat (limited to 'makefu/2configs/hw/tp-x2x0.nix')
-rw-r--r--makefu/2configs/hw/tp-x2x0.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/2configs/hw/tp-x2x0.nix b/makefu/2configs/hw/tp-x2x0.nix
new file mode 100644
index 00000000..aa2fc205
--- /dev/null
+++ b/makefu/2configs/hw/tp-x2x0.nix
@@ -0,0 +1,26 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ # TODO: put this somewhere else
+ networking.wireless.enable = true;
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+
+ zramSwap.enable = true;
+ zramSwap.numDevices = 2;
+
+ hardware.trackpoint = {
+ enable = true;
+ sensitivity = 220;
+ speed = 220;
+ emulateWheel = true;
+ };
+
+
+ services.tlp.enable = true;
+ services.tlp.extraConfig = ''
+ START_CHARGE_THRESH_BAT0=80
+ '';
+}