summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/tp-x230.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-10-27 14:55:50 +0200
committermakefu <github@syntax-fehler.de>2016-10-27 14:55:50 +0200
commit2e22fa7234c95cccb1680fb47954f339e6e0b326 (patch)
treea2ef52330bd7cc303df4665bd1f94e0077debc63 /makefu/2configs/hw/tp-x230.nix
parent32fff8c80eb49a0b8a121e487915f808ddbd7ea8 (diff)
m 2 hw: Plot twist - x220 was an x230 ALL ALONG!
Diffstat (limited to 'makefu/2configs/hw/tp-x230.nix')
-rw-r--r--makefu/2configs/hw/tp-x230.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/makefu/2configs/hw/tp-x230.nix b/makefu/2configs/hw/tp-x230.nix
new file mode 100644
index 00000000..99563a77
--- /dev/null
+++ b/makefu/2configs/hw/tp-x230.nix
@@ -0,0 +1,44 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+{
+
+ imports = [ ./tp-x2x0.nix ];
+ boot = {
+ # tp-smapi is not supported bt x230 anymore
+ kernelModules = [
+ "kvm-intel"
+ "thinkpad_ec"
+ # "acpi_call"
+ # "thinkpad_acpi"
+ # "tpm-rng"
+ ];
+ extraModulePackages = [
+ # config.boot.kernelPackages.acpi_call
+ ];
+ };
+ services.acpid.enable = true;
+ hardware.opengl.extraPackages = [ pkgs.vaapiIntel pkgs.vaapiVdpau ];
+ services.xserver = {
+ videoDriver = "intel";
+ deviceSection = ''
+ Option "AccelMethod" "sna"
+ '';
+ };
+ # no entropy source working
+ # security.rngd.enable = true;
+
+ services.xserver.displayManager.sessionCommands =''
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
+ xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
+ xinput set-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Axes" 6 7 4 5
+ # xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Timeout" 8 200
+ '';
+
+ # enable HDMI output switching with pulseaudio
+ hardware.pulseaudio.configFile = pkgs.writeText "pulse-default-pa" ''
+ ${builtins.readFile "${config.hardware.pulseaudio.package.out}/etc/pulse/default.pa"}
+ load-module module-alsa-sink device=hw:0,3 sink_properties=device.description="HDMIOutput" sink_name="HDMI"
+ '';
+
+}