summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/hw/bluetooth.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-05-31 10:33:08 +0200
committermakefu <github@syntax-fehler.de>2018-05-31 10:33:08 +0200
commit5dd486eabdec439cc67b2341519d1afdd577c34f (patch)
treea9ab2eb5d9401a30c5a2d37c57d7d2ea60a74255 /makefu/2configs/hw/bluetooth.nix
parente6794ca8821fd37bf0fcd2966b9927c14e92d180 (diff)
ma bluetooth: separate file
Diffstat (limited to 'makefu/2configs/hw/bluetooth.nix')
-rw-r--r--makefu/2configs/hw/bluetooth.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/makefu/2configs/hw/bluetooth.nix b/makefu/2configs/hw/bluetooth.nix
new file mode 100644
index 00000000..85c3190f
--- /dev/null
+++ b/makefu/2configs/hw/bluetooth.nix
@@ -0,0 +1,39 @@
+{ pkgs, ... }:
+{ # bluetooth+pulse config
+# for blueman-applet
+ users.users.makefu.packages = [
+ pkgs.blueman
+ ];
+ hardware.pulseaudio = {
+ enable = true;
+ package = pkgs.pulseaudioFull;
+# systemWide = true;
+ support32Bit = true;
+ configFile = pkgs.writeText "default.pa" ''
+ load-module module-udev-detect
+ load-module module-bluetooth-policy
+ load-module module-bluetooth-discover
+ load-module module-native-protocol-unix
+ load-module module-always-sink
+ load-module module-console-kit
+ load-module module-systemd-login
+ load-module module-intended-roles
+ load-module module-position-event-sounds
+ load-module module-filter-heuristics
+ load-module module-filter-apply
+ load-module module-switch-on-connect
+ load-module module-switch-on-port-available
+ '';
+ };
+
+# presumably a2dp Sink
+# Enable profile:
+## pacmd set-card-profile "$(pactl list cards short | egrep -o bluez_card[[:alnum:]._]+)" a2dp_sink
+ hardware.bluetooth.extraConfig = '';
+ [general]
+ Enable=Source,Sink,Media,Socket
+ '';
+
+# connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
+ hardware.bluetooth.enable = true;
+}