summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/home/ham/automation/keller_buttons.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-08-27 22:45:16 +0200
committermakefu <github@syntax-fehler.de>2021-08-27 22:45:16 +0200
commit2c9923264e318ad83ab9ceb4a13e47112dff0d4f (patch)
tree757d2841b57ec6792ab9959d0f00bb020dfc46fa /makefu/2configs/home/ham/automation/keller_buttons.nix
parent57bf42286dba8b20cfdc02e28b4dc4a0a9291765 (diff)
ma ham: add keller button logic
Diffstat (limited to 'makefu/2configs/home/ham/automation/keller_buttons.nix')
-rw-r--r--makefu/2configs/home/ham/automation/keller_buttons.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/makefu/2configs/home/ham/automation/keller_buttons.nix b/makefu/2configs/home/ham/automation/keller_buttons.nix
new file mode 100644
index 00000000..598dc7df
--- /dev/null
+++ b/makefu/2configs/home/ham/automation/keller_buttons.nix
@@ -0,0 +1,7 @@
+let
+ inherit (../lib) btn_cycle_light;
+in {
+ services.home-assistant.config.automation = [
+ (btn_cycle_light "light.keller_osram" "keller_btn1" 128)
+ ];
+}