summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fs/cac-boot-partition.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
committermakefu <github@syntax-fehler.de>2015-09-02 10:02:05 +0200
commit37744f0016b77af41e8f57bc6da32b15f5ac50fd (patch)
treef51174cd0c20364eb9f4b03342dbaed7250a7729 /makefu/2configs/fs/cac-boot-partition.nix
parentf911d43005d043ca360837eb8b3c2c2fe30bc962 (diff)
makefu: sort 2configs
Diffstat (limited to 'makefu/2configs/fs/cac-boot-partition.nix')
-rw-r--r--makefu/2configs/fs/cac-boot-partition.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/makefu/2configs/fs/cac-boot-partition.nix b/makefu/2configs/fs/cac-boot-partition.nix
new file mode 100644
index 00000000..fdf4b89d
--- /dev/null
+++ b/makefu/2configs/fs/cac-boot-partition.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+# vda1 ext4 (label nixos) -> only root partition
+with lib;
+{
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/sda";
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-label/boot";
+ fsType = "ext4";
+ };
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+}