summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fetchWallpaper.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-02-11 11:04:19 +0100
committermakefu <github@syntax-fehler.de>2016-02-11 11:04:19 +0100
commita649befbfafaff80d1d1a10896bfc4343021797b (patch)
treea88e088bfc9e2d9744a0114dfd5d71ea8f4796d2 /makefu/2configs/fetchWallpaper.nix
parent4c23e33dea4d9901b64bf287983c43862f4990f2 (diff)
k 3 fetchWallpaper: scrap predicate, use unitConfig
Diffstat (limited to 'makefu/2configs/fetchWallpaper.nix')
-rw-r--r--makefu/2configs/fetchWallpaper.nix15
1 files changed, 3 insertions, 12 deletions
diff --git a/makefu/2configs/fetchWallpaper.nix b/makefu/2configs/fetchWallpaper.nix
index b071a128..786df6d4 100644
--- a/makefu/2configs/fetchWallpaper.nix
+++ b/makefu/2configs/fetchWallpaper.nix
@@ -1,24 +1,15 @@
{ config, pkgs, ... }:
-let
- # check if laptop runs on umts
- weaksauce-internet = with pkgs;writeScript "weaksauce-internet" ''
- #! /bin/sh
- if ${iproute}/bin/ip addr show dev ppp0 2>/dev/null \
- | ${gnugrep}/bin/grep -q inet;then
- exit 1
- fi
- '';
-
-in {
+{
krebs.fetchWallpaper = {
enable = true;
display = ":0";
- predicate = weaksauce-internet;
+ unitConfig.ConditionPathExists = "!/var/run/ppp0.pid";
timerConfig = {
OnCalendar = "*:0/30";
};
url = "http://echelon/wallpaper.png";
};
+
}