summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fetchWallpaper.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-13 13:52:15 +0100
committermakefu <github@syntax-fehler.de>2015-12-13 13:52:15 +0100
commit6a07012a2f2ab8673c464256bd46efedf95366c3 (patch)
treee7add0c72409e00ecf29f8cd5fb0e419a8b8c8d7 /makefu/2configs/fetchWallpaper.nix
parent1c17881aede650e114b43dfb4efb10249c2bcaea (diff)
m 2 fetchWallpaper: default enabled for mainlaptop
Diffstat (limited to 'makefu/2configs/fetchWallpaper.nix')
-rw-r--r--makefu/2configs/fetchWallpaper.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/2configs/fetchWallpaper.nix b/makefu/2configs/fetchWallpaper.nix
new file mode 100644
index 00000000..b071a128
--- /dev/null
+++ b/makefu/2configs/fetchWallpaper.nix
@@ -0,0 +1,24 @@
+{ config, pkgs, ... }:
+
+let
+ # check if laptop runs on umts
+ weaksauce-internet = with pkgs;writeScript "weaksauce-internet" ''
+ #! /bin/sh
+ if ${iproute}/bin/ip addr show dev ppp0 2>/dev/null \
+ | ${gnugrep}/bin/grep -q inet;then
+ exit 1
+ fi
+ '';
+
+in {
+ krebs.fetchWallpaper = {
+ enable = true;
+ display = ":0";
+ predicate = weaksauce-internet;
+ timerConfig = {
+ OnCalendar = "*:0/30";
+ };
+ url = "http://echelon/wallpaper.png";
+ };
+}
+