summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/deployment/owncloud.nix
diff options
context:
space:
mode:
authorexco <Christian.Stoeveken@gmail.com>2020-10-23 20:56:32 +0200
committermakefu <github@syntax-fehler.de>2020-10-23 20:58:21 +0200
commitfd41a76d4cab2765f9ef95ce5322b7bffe52b8a7 (patch)
treeef1d56dfe240ae3aa690a16591c2ba3f8eeb6ed7 /makefu/2configs/deployment/owncloud.nix
parent9ad7c3114b407833a8e3394e4deee5188a07e7b8 (diff)
ma deployment/owncloud: fix deprecated .extraConfig and .listen.
Mic92, lassulus ftw.
Diffstat (limited to 'makefu/2configs/deployment/owncloud.nix')
-rw-r--r--makefu/2configs/deployment/owncloud.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/makefu/2configs/deployment/owncloud.nix b/makefu/2configs/deployment/owncloud.nix
index 1cfda6fc..317e0a29 100644
--- a/makefu/2configs/deployment/owncloud.nix
+++ b/makefu/2configs/deployment/owncloud.nix
@@ -98,7 +98,7 @@ let
fastcgi_param PATH_INFO $fastcgi_path_info;
fastcgi_param HTTPS on;
fastcgi_param modHeadersAvailable true; #Avoid sending the security headers twice
- fastcgi_pass unix:${socket};
+ fastcgi_pass unix:${config.services.phpfpm.pools.${domain}.socket};
fastcgi_intercept_errors on;
'';
@@ -126,7 +126,6 @@ let
services.phpfpm.pools."${domain}" = {
user = "nginx";
group = "nginx";
- listen = socket;
settings = {
"listen.owner" = "nginx";
"pm" = "dynamic";
@@ -135,13 +134,11 @@ let
"pm.start_servers" = 2;
"pm.min_spare_servers" = 2;
"pm.max_spare_servers" = 5;
+ "php_admin_value[error_log]" = "stderr";
+ "php_admin_flag[log_errors]" = "on";
+ "catch_workers_output" = true;
};
- extraConfig = ''
- php_admin_value[error_log] = 'stderr'
- php_admin_flag[log_errors] = on
- env[PATH] = ${lib.makeBinPath [ pkgs.php ]}
- catch_workers_output = yes
- '';
+ phpEnv."PATH" = lib.makeBinPath [ pkgs.php ];
};
services.phpfpm.phpOptions = ''
opcache.enable=1