summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-13 14:35:30 +0100
committermakefu <github@syntax-fehler.de>2015-12-13 14:35:30 +0100
commit809ffa435c4ba759a6cfd7fdffc976499d470d82 (patch)
treeead297c46101fb82dec02a577fcdbcf658cc8d66 /makefu/2configs/default.nix
parent4578f701ba01bfdf0745a8c73461070f0f7d2f0e (diff)
m 2 default: use timesyncd instead of ntpd
Diffstat (limited to 'makefu/2configs/default.nix')
-rw-r--r--makefu/2configs/default.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/makefu/2configs/default.nix b/makefu/2configs/default.nix
index 760c7078..51963528 100644
--- a/makefu/2configs/default.nix
+++ b/makefu/2configs/default.nix
@@ -80,7 +80,14 @@ with lib;
"d /tmp 1777 root root - -"
];
- environment.variables.EDITOR = mkForce "vim";
+ environment.variables = {
+ NIX_PATH = with config.krebs.build.source; with dir; with git;
+ mkForce (concatStringsSep ":" [
+ "nixpkgs=${nixpkgs.target-path}"
+ "${nixpkgs.target-path}"
+ ]);
+ EDITOR = mkForce "vim";
+ };
environment.systemPackages = with pkgs; [
jq
@@ -124,6 +131,14 @@ with lib;
services.cron.enable = false;
services.nscd.enable = false;
+ services.ntp.enable = false;
+ services.timesyncd.enable = true;
+ services.ntp.servers = [
+ "pool.ntp.org"
+ "time.windows.com"
+ "time.apple.com"
+ "time.nist.gov"
+ ];
security.setuidPrograms = [ "sendmail" ];
services.journald.extraConfig = ''