summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/switch/tasmota_switch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-04-04 22:55:24 +0200
committermakefu <github@syntax-fehler.de>2019-04-04 22:55:24 +0200
commit5761d563f5db527fb0e82e226efa42d029d31d21 (patch)
tree72f4e319948819535483743048d536bac9e8eac6 /makefu/2configs/bureautomation/switch/tasmota_switch.nix
parent197064cdba91649fd2e94e57d4ba54a0a3ea4b85 (diff)
ma bureautomation: use tele/STATE instead of stat/POWER
Diffstat (limited to 'makefu/2configs/bureautomation/switch/tasmota_switch.nix')
-rw-r--r--makefu/2configs/bureautomation/switch/tasmota_switch.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/makefu/2configs/bureautomation/switch/tasmota_switch.nix b/makefu/2configs/bureautomation/switch/tasmota_switch.nix
index eb7b5fb8..115bae0c 100644
--- a/makefu/2configs/bureautomation/switch/tasmota_switch.nix
+++ b/makefu/2configs/bureautomation/switch/tasmota_switch.nix
@@ -2,13 +2,16 @@ let
tasmota_plug = name: topic:
{ platform = "mqtt";
inherit name;
- state_topic = "/bam/${topic}/stat/POWER";
+ state_topic = "/bam/${topic}/tele/STATE";
+ value_template = "{{ value_json.POWER }}";
command_topic = "/bam/${topic}/cmnd/POWER";
availability_topic = "/bam/${topic}/tele/LWT";
payload_on= "ON";
payload_off= "OFF";
payload_available= "Online";
payload_not_available= "Offline";
+ retain = false;
+ qos = 1;
};
in [
(tasmota_plug "Bauarbeiterlampe" "plug")