summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/gtts-token.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
committermakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
commitea8d45793ef7375dcb9c324d1a235f47898fdef3 (patch)
treedd4ac0e37bef48882d599f9f34c837f785de2896 /makefu/2configs/bureautomation/gtts-token.nix
parent64eee34bbeac88ef8c4c27c8b4245ac0aaa7bfe7 (diff)
ma bureautomation: prepare dwd_pollen, update presence
Diffstat (limited to 'makefu/2configs/bureautomation/gtts-token.nix')
-rw-r--r--makefu/2configs/bureautomation/gtts-token.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/gtts-token.nix b/makefu/2configs/bureautomation/gtts-token.nix
new file mode 100644
index 00000000..69640f03
--- /dev/null
+++ b/makefu/2configs/bureautomation/gtts-token.nix
@@ -0,0 +1,27 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, requests
+}:
+
+buildPythonPackage rec {
+ pname = "gtts-token";
+ version = "1.1.3";
+
+ src = fetchPypi {
+ pname = "gTTS-token";
+ inherit version;
+ sha256 = "9d6819a85b813f235397ef931ad4b680f03d843c9b2a9e74dd95175a4bc012c5";
+ };
+
+ propagatedBuildInputs = [
+ requests
+ ];
+
+ meta = with lib; {
+ description = "Calculates a token to run the Google Translate text to speech";
+ homepage = https://github.com/boudewijn26/gTTS-token;
+ license = licenses.mit;
+ # maintainers = [ maintainers. ];
+ };
+}