summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/dwd_pollen.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
committermakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
commitea8d45793ef7375dcb9c324d1a235f47898fdef3 (patch)
treedd4ac0e37bef48882d599f9f34c837f785de2896 /makefu/2configs/bureautomation/dwd_pollen.nix
parent64eee34bbeac88ef8c4c27c8b4245ac0aaa7bfe7 (diff)
ma bureautomation: prepare dwd_pollen, update presence
Diffstat (limited to 'makefu/2configs/bureautomation/dwd_pollen.nix')
-rw-r--r--makefu/2configs/bureautomation/dwd_pollen.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/dwd_pollen.nix b/makefu/2configs/bureautomation/dwd_pollen.nix
new file mode 100644
index 00000000..39d9c306
--- /dev/null
+++ b/makefu/2configs/bureautomation/dwd_pollen.nix
@@ -0,0 +1,32 @@
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
+, python
+, voluptuous
+}:
+
+buildPythonPackage rec {
+ format = "other";
+ pname = "dwd_pollen";
+ version = "0.1";
+
+ src = fetchFromGitHub {
+ owner = "marcschumacher";
+ repo = "dwd_pollen";
+ rev = version;
+ sha256 = "1af2mx99gv2hk1ad53g21fwkdfdbymqcdl3jvzd1yg7dgxlkhbj1";
+ };
+ propagatedBuildInputs = [
+ voluptuous
+ ];
+ installPhase = ''
+ install -D -t $out/${python.sitePackages}/homeassistant/components/sensor/dwd_pollen *
+ '';
+
+ meta = with lib; {
+ description = "Home Assistant component to retrieve Pollen data from DWD (Germany)";
+ homepage = https://github.com/marcschumacher/dwd_pollen;
+ license = licenses.mit;
+ maintainers = [ maintainers.makefu ];
+ };
+}