summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
committermakefu <github@syntax-fehler.de>2019-06-17 07:54:31 +0200
commitea8d45793ef7375dcb9c324d1a235f47898fdef3 (patch)
treedd4ac0e37bef48882d599f9f34c837f785de2896 /makefu/2configs/bureautomation/default.nix
parent64eee34bbeac88ef8c4c27c8b4245ac0aaa7bfe7 (diff)
ma bureautomation: prepare dwd_pollen, update presence
Diffstat (limited to 'makefu/2configs/bureautomation/default.nix')
-rw-r--r--makefu/2configs/bureautomation/default.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/makefu/2configs/bureautomation/default.nix b/makefu/2configs/bureautomation/default.nix
index 1782becd..56c84574 100644
--- a/makefu/2configs/bureautomation/default.nix
+++ b/makefu/2configs/bureautomation/default.nix
@@ -24,22 +24,20 @@ in {
./ota.nix
];
services.logstash = {
- package = pkgs.logstash5;
+ package = pkgs.logstash7;
+ plugins = [ pkgs.logstash-output-exec ];
enable = true;
inputConfig = ''
http {
port => ${toString port}
host => "127.0.0.1"
+ type => "schlechteluft"
}
'';
- filterConfig = ''
- '';
outputConfig = ''
- stdout { codec => json }
- exec { command => "${runit} '%{ruleName}' '%{state}'" }
- '';
- extraSettings = ''
- path.plugins: [ "${pkgs.logstash-output-exec}" ]
+ if [type] == "schlechteluft" {
+ exec { command => "${runit} '%{ruleName}' '%{state}'" }
+ }
'';
};
}