summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/binary_sensor/buttons.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-03-12 11:16:45 +0100
committerlassulus <lassulus@lassul.us>2019-03-12 11:16:45 +0100
commitc4ebcc43d2b2f2451b16ee453f5275bd46018cd4 (patch)
tree64c85c3943ded41140866811c2838cfb8e6c4b92 /makefu/2configs/bureautomation/binary_sensor/buttons.nix
parent44540e08146438e99840c6aff1af1b9a312d54ed (diff)
parentda5fb52eb08097565c0e78035beb14a8a0ab2366 (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/bureautomation/binary_sensor/buttons.nix')
-rw-r--r--makefu/2configs/bureautomation/binary_sensor/buttons.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/makefu/2configs/bureautomation/binary_sensor/buttons.nix b/makefu/2configs/bureautomation/binary_sensor/buttons.nix
new file mode 100644
index 00000000..e23c4a36
--- /dev/null
+++ b/makefu/2configs/bureautomation/binary_sensor/buttons.nix
@@ -0,0 +1,17 @@
+let
+ tasmota_button = name: topic:
+ # detects a pushbutton press from tasmota
+ { platform = "mqtt";
+ inherit name;
+ state_topic = "/bam/${topic}/cmnd/POWER";
+ availability_topic = "/bam/${topic}/tele/LWT";
+ payload_on = "ON";
+ payload_off = "OFF";
+ payload_available= "Online";
+ payload_not_available= "Offline";
+ # expire_after = "5"; #expire after 5 seconds
+ qos = 1;
+ };
+in [
+ (tasmota_button "RedButton" "redbutton")
+]