summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bureautomation/binary_sensor/buttons.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
committermakefu <github@syntax-fehler.de>2023-07-28 22:24:15 +0200
commit060a8f28fa1fc648bdf66afb31a5d1efac868837 (patch)
tree2b354eacc7897365ee45244fe7a51720e0d0333f /makefu/2configs/bureautomation/binary_sensor/buttons.nix
parentcbfcc890e3b76d942b927809bf981a5fa7289e6a (diff)
makefu: move out to own repo, add vacation-note
Diffstat (limited to 'makefu/2configs/bureautomation/binary_sensor/buttons.nix')
-rw-r--r--makefu/2configs/bureautomation/binary_sensor/buttons.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/makefu/2configs/bureautomation/binary_sensor/buttons.nix b/makefu/2configs/bureautomation/binary_sensor/buttons.nix
deleted file mode 100644
index 20590a6b..00000000
--- a/makefu/2configs/bureautomation/binary_sensor/buttons.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-let
- tasmota_button = name: topic:
- # detects a pushbutton press from tasmota
- { platform = "mqtt";
- inherit name;
- state_topic = "/bam/${topic}/cmnd/POWER";
- availability_topic = "/bam/${topic}/tele/LWT";
- payload_on = "ON";
- payload_off = "OFF";
- payload_available= "Online";
- payload_not_available= "Offline";
- # expire_after = "5"; #expire after 5 seconds
- qos = 1;
- };
-in {
- services.home-assistant.config.binary_sensor =
- [
- (tasmota_button "RedButton" "redbutton")
- ];
-}