summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bgt/download.binaergewitter.de.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-28 17:00:39 +0100
committermakefu <github@syntax-fehler.de>2018-11-28 17:00:39 +0100
commit26c897d72ce24a300b871a737c74742f35221006 (patch)
treeb26353bd0fbceb13b70fd30f191474dc8ddc0886 /makefu/2configs/bgt/download.binaergewitter.de.nix
parent7ee2e1e266b9373d79644cbc17c179dbc02fc2cb (diff)
ma bgt: init download.binaergewitter.de
Diffstat (limited to 'makefu/2configs/bgt/download.binaergewitter.de.nix')
-rw-r--r--makefu/2configs/bgt/download.binaergewitter.de.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/makefu/2configs/bgt/download.binaergewitter.de.nix b/makefu/2configs/bgt/download.binaergewitter.de.nix
new file mode 100644
index 00000000..6d64848f
--- /dev/null
+++ b/makefu/2configs/bgt/download.binaergewitter.de.nix
@@ -0,0 +1,38 @@
+{ config, lib, pkgs, ... }:
+
+with import <stockholm/lib>;
+let
+ ident = (builtins.readFile ./auphonic.pub);
+in {
+ services.openssh = {
+ allowSFTP = true;
+ sftpFlags = [ "-l VERBOSE" ];
+ extraConfig = ''
+ Match User auphonic
+ ForceCommand internal-sftp
+ AllowTcpForwarding no
+ X11Forwarding no
+ PasswordAuthentication no
+ '';
+ };
+ users.users.auphonic = {
+ uid = genid "auphonic";
+ group = "nginx";
+ useDefaultShell = true;
+ openssh.authorizedKeys.keys = [ ident config.krebs.users.makefu.pubkey ];
+ };
+ services.nginx = {
+ enable = lib.mkDefault true;
+ recommendedGzipSettings = true;
+ recommendedOptimisation = true;
+ virtualHosts."download.binaergewitter.de" = {
+ serverAliases = [ "dl2.binaergewitter.de" ];
+ root = "/var/www/binaergewitter";
+ extraConfig = ''
+ access_log /var/spool/nginx/logs/binaergewitter.access.log combined;
+ error_log /var/spool/nginx/logs/binaergewitter.error.log error;
+ autoindex on;
+ '';
+ };
+ };
+}