summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-02-21 16:00:33 +0100
committermakefu <github@syntax-fehler.de>2018-02-21 16:00:33 +0100
commitc4fdec7ce910c319c675388c59a65c44d202d5b1 (patch)
tree4ca2d0d67b7930c32a64eb31f173925f58d3926b /makefu/1systems/x/config.nix
parentebb5d67cf320b3fdaf7966f503fff54cfda3b637 (diff)
ma x.r: add bluetooth
Diffstat (limited to 'makefu/1systems/x/config.nix')
-rw-r--r--makefu/1systems/x/config.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/makefu/1systems/x/config.nix b/makefu/1systems/x/config.nix
index b4d4aa66..ad2ad877 100644
--- a/makefu/1systems/x/config.nix
+++ b/makefu/1systems/x/config.nix
@@ -100,7 +100,43 @@ with import <stockholm/lib>;
];
};
}
+ { # bluetooth+pulse config
+ # for blueman-applet
+ users.users.makefu.packages = [
+ pkgs.blueman
+ ];
+ hardware.pulseaudio = {
+ enable = true;
+ package = pkgs.pulseaudioFull;
+ # systemWide = true;
+ support32Bit = true;
+ configFile = pkgs.writeText "default.pa" ''
+ load-module module-udev-detect
+ load-module module-bluetooth-policy
+ load-module module-bluetooth-discover
+ load-module module-native-protocol-unix
+ load-module module-always-sink
+ load-module module-console-kit
+ load-module module-systemd-login
+ load-module module-intended-roles
+ load-module module-position-event-sounds
+ load-module module-filter-heuristics
+ load-module module-filter-apply
+ load-module module-switch-on-connect
+ '';
+ };
+ # presumably a2dp Sink
+ # Enable profile:
+ ## pacmd set-card-profile "$(pactl list cards short | egrep -o bluez_card[[:alnum:]._]+)" a2dp_sink
+ hardware.bluetooth.extraConfig = '';
+ [general]
+ Enable=Source,Sink,Media,Socket
+ '';
+
+ # connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
+ hardware.bluetooth.enable = true;
+ }
{ # auto-mounting
services.udisks2.enable = true;
services.devmon.enable = true;