summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-04-04 14:44:06 +0200
committermakefu <github@syntax-fehler.de>2018-04-04 14:44:06 +0200
commit0d4bb21df59c08eccf5db522242d3cb80f2b9425 (patch)
treeceeafd008a4df9aab53ec8a4bc751123f2be1b98 /makefu/1systems/x/config.nix
parenta2c1afe2a253589bc38380a75c7b156216b40667 (diff)
ma automatic-diskmount: put into separate config
Diffstat (limited to 'makefu/1systems/x/config.nix')
-rw-r--r--makefu/1systems/x/config.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/makefu/1systems/x/config.nix b/makefu/1systems/x/config.nix
index 483fc81e..93bb27ef 100644
--- a/makefu/1systems/x/config.nix
+++ b/makefu/1systems/x/config.nix
@@ -141,48 +141,6 @@ with import <stockholm/lib>;
# connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
hardware.bluetooth.enable = true;
}
- { # auto-mounting via polkit
- services.udisks2.enable = true;
- ## automount all disks:
- # services.devmon.enable = true;
- # services.gnome3.gvfs.enable = true;
- users.groups.storage = {
- gid = genid "storage";
- members = [ "makefu" ];
- };
- users.users.makefu.packages = with pkgs;[
- gvfs pcmanfm lxmenu-data
- ];
- environment.variables.GIO_EXTRA_MODULES = [ "${pkgs.gvfs}/lib/gio/modules" ];
-
- ## allow users in group "storage" to mount disk
- # https://github.com/coldfix/udiskie/wiki/Permissions
- security.polkit.extraConfig =
- ''
- polkit.addRule(function(action, subject) {
- var YES = polkit.Result.YES;
- var permission = {
- "org.freedesktop.udisks.filesystem-mount": YES,
- "org.freedesktop.udisks.luks-unlock": YES,
- "org.freedesktop.udisks.drive-eject": YES,
- "org.freedesktop.udisks.drive-detach": YES,
- "org.freedesktop.udisks2.filesystem-mount": YES,
- "org.freedesktop.udisks2.encrypted-unlock": YES,
- "org.freedesktop.udisks2.eject-media": YES,
- "org.freedesktop.udisks2.power-off-drive": YES,
- "org.freedesktop.udisks2.filesystem-mount-other-seat": YES,
- "org.freedesktop.udisks2.filesystem-unmount-others": YES,
- "org.freedesktop.udisks2.encrypted-unlock-other-seat": YES,
- "org.freedesktop.udisks2.eject-media-other-seat": YES,
- "org.freedesktop.udisks2.power-off-drive-other-seat": YES
- };
- if (subject.isInGroup("storage")) {
- return permission[action.id];
- }
- });
- '';
-
- }
];