summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wbob.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-07-20 20:35:30 +0200
committermakefu <github@syntax-fehler.de>2016-07-20 20:35:30 +0200
commite03ae6d79d77e654bb586475b52c7e6aa24ac06f (patch)
tree30b65d3e4aa7425180fea6f1cabd0091f0529d41 /makefu/1systems/wbob.nix
parentdf7416dc319e6815e32fa5fb32ba00d41481d368 (diff)
m 1 wbob: add missing
Diffstat (limited to 'makefu/1systems/wbob.nix')
-rw-r--r--makefu/1systems/wbob.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/makefu/1systems/wbob.nix b/makefu/1systems/wbob.nix
index 45b935af..e8e0b091 100644
--- a/makefu/1systems/wbob.nix
+++ b/makefu/1systems/wbob.nix
@@ -1,5 +1,7 @@
{ config, pkgs, ... }:
-{
+let rootdisk = "/dev/disk/by-id/ata-TS256GMTS800_C613840115";
+in {
+
makefu.awesome = {
modkey = "Mod1";
#TODO: integrate kiosk config into full config by templating the autostart
@@ -9,19 +11,19 @@
[ # Include the results of the hardware scan.
../.
../2configs/main-laptop.nix
+ ../2configs/virtualization.nix
+ ../2configs/tinc/retiolum.nix
];
krebs = {
enable = true;
- retiolum.enable = true;
build.host = config.krebs.hosts.wbob;
};
networking.firewall.allowedUDPPorts = [ 1655 ];
- networking.firewall.allowedTCPPorts = [ 1655 ];
+ networking.firewall.allowedTCPPorts = [ 1655 49152 ];
services.tinc.networks.siem = {
name = "display";
extraConfig = ''
ConnectTo = sjump
- Port = 1655
'';
};
@@ -35,12 +37,12 @@
# nuc hardware
- boot.loader.grub.device = "/dev/sda";
+ boot.loader.grub.device = rootdisk;
hardware.cpu.intel.updateMicrocode = true;
boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "usbhid" "usb_storage" "sd_mod" ];
boot.kernelModules = [ "kvm-intel" ];
fileSystems."/" = {
- device = "/dev/sda1";
+ device = rootdisk + "-part1";
fsType = "ext4";
};