summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/shoney.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-06-13 16:22:51 +0200
committermakefu <github@syntax-fehler.de>2016-06-13 16:22:51 +0200
commitf256bbcb11565138e92266e97856438061b623a0 (patch)
tree7716c4caccd23adb8a3f9eae772ba5c3d892f38e /makefu/1systems/shoney.nix
parentb9c0c46b4d0f9907f1b3fc96494be96abc60c8db (diff)
cp tv/2/*CAC -> makefu/2/
Diffstat (limited to 'makefu/1systems/shoney.nix')
-rw-r--r--makefu/1systems/shoney.nix22
1 files changed, 14 insertions, 8 deletions
diff --git a/makefu/1systems/shoney.nix b/makefu/1systems/shoney.nix
index ebe5222c..16e89199 100644
--- a/makefu/1systems/shoney.nix
+++ b/makefu/1systems/shoney.nix
@@ -1,15 +1,19 @@
{ config, pkgs, ... }:
let
- ip = "64.137.235.70";
- gw = "64.137.235.1";
+ ip = "64.137.234.215";
+ alt-ip = "64.137.234.210";
+ extra-ip = "64.137.234.114"; #currently unused
+ gw = "64.137.234.1";
in {
imports = [
../.
- ../../tv/2configs/hw/CAC.nix
- ../../tv/2configs/fs/CAC-CentOS-7-64bit.nix
+ ../2configs/hw/CAC.nix
+ ../2configs/fs/CAC-CentOS-7-64bit.nix
];
+
+
# minimal resources
services.nixosManual.enable = false;
programs.man.enable = false;
@@ -21,10 +25,12 @@ in {
retiolum.enable = true;
build.host = config.krebs.hosts.shoney;
};
- networking.interfaces.enp2s1.ip4 = [ {
- address = ip;
- prefixLength = 24;
- } ];
+ networking.interfaces.enp2s1.ip4 = [
+ { address = ip; prefixLength = 24; }
+ { address = alt-ip; prefixLength = 24; }
+ ];
networking.defaultGateway = gw;
networking.nameservers = [ "8.8.8.8" ];
+ networking.firewall.allowedUDPPorts = [ 655 1655 ];
+ networking.firewall.allowedTCPPorts = [ 655 1655 ];
}