summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/repunit.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-29 15:41:38 +0200
committermakefu <github@syntax-fehler.de>2015-07-29 15:41:38 +0200
commitd516f329dae8e3d282ab699227667995ce1b2bee (patch)
tree1623242549b312e4243274cb9e747b3fcfe357da /makefu/1systems/repunit.nix
parentb14e55d25aa3c42685b8bab3bd9b52e53c22426f (diff)
prepare repunit
Diffstat (limited to 'makefu/1systems/repunit.nix')
-rw-r--r--makefu/1systems/repunit.nix63
1 files changed, 63 insertions, 0 deletions
diff --git a/makefu/1systems/repunit.nix b/makefu/1systems/repunit.nix
index e69de29b..7596a3d5 100644
--- a/makefu/1systems/repunit.nix
+++ b/makefu/1systems/repunit.nix
@@ -0,0 +1,63 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ../2configs/base.nix
+ ../2configs/cgit-retiolum.nix
+ ];
+ krebs.build.host = config.krebs.hosts.repunit;
+ krebs.build.user = config.krebs.users.makefu;
+ krebs.build.target = "root@repunit";
+
+ krebs.build.deps = {
+ nixpkgs = {
+ url = https://github.com/NixOS/nixpkgs;
+ rev = "4c01e6d91993b6de128795f4fbdd25f6227fb870";
+ };
+ secrets = {
+ url = "/home/makefu/secrets/${config.krebs.build.host.name}";
+ };
+ stockholm = {
+ url = toString ../..;
+ };
+ };
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "ehci_pci" "virtio_pci" "virtio_blk" ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+# networking.firewall is enabled by default
+ networking.firewall.allowedTCPPorts = [ 80 ];
+ networking.firewall.allowPing = true;
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+ krebs.retiolum = {
+ enable = true;
+ hosts = ../../Zhosts;
+ connectTo = [
+ "gum"
+ "pigstarter"
+ "fastpoke"
+ ];
+ };
+
+# $ nix-env -qaP | grep wget
+ environment.systemPackages = with pkgs; [
+ jq
+ ];
+}