summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/pnp.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-08-05 14:56:38 +0200
committermakefu <github@syntax-fehler.de>2015-08-05 15:01:05 +0200
commitb3c25831d1ac80578222cc7d0e8f3559f92f34c1 (patch)
tree93d50afbaaf74ae07ffe252fc93c088ef0dfcd75 /makefu/1systems/pnp.nix
parenta385b9a4ec7751276c81e09b51427b22a344c9a3 (diff)
add graphite to pnp
Diffstat (limited to 'makefu/1systems/pnp.nix')
-rw-r--r--makefu/1systems/pnp.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/makefu/1systems/pnp.nix b/makefu/1systems/pnp.nix
index 54965898..a8df522f 100644
--- a/makefu/1systems/pnp.nix
+++ b/makefu/1systems/pnp.nix
@@ -10,6 +10,7 @@
<nixpkgs/nixos/modules/profiles/qemu-guest.nix>
../2configs/base.nix
../2configs/cgit-retiolum.nix
+ ../2configs/graphite-standalone.nix
];
krebs.build.host = config.krebs.hosts.pnp;
krebs.build.user = config.krebs.users.makefu;
@@ -38,8 +39,13 @@
hardware.enableAllFirmware = true;
hardware.cpu.amd.updateMicrocode = true;
-# networking.firewall is enabled by default
- networking.firewall.allowedTCPPorts = [ 80 ];
+ networking.firewall.allowedTCPPorts = [
+ # nginx runs on 80
+ 80
+ # graphite-web runs on 8080, carbon cache runs on 2003 tcp and udp
+ 8080 2003
+ ];
+ networking.firewall.allowedUDPPorts = [ 2003 ];
networking.firewall.rejectPackets = true;
networking.firewall.allowPing = true;