summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/pnp.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-28 20:19:54 +0200
committermakefu <github@syntax-fehler.de>2015-07-28 20:19:54 +0200
commit0b00e7e70eefd3b22b65a29506003bd984dfb6f2 (patch)
tree8cd21d808f0d432f4dca31b94ba992a1983ae5f6 /makefu/1systems/pnp.nix
parent5e8b783d0a71c08999aa033a0c8997ca0d8ba1cd (diff)
makefu:rename to user-toplevel structure
Diffstat (limited to 'makefu/1systems/pnp.nix')
-rw-r--r--makefu/1systems/pnp.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/makefu/1systems/pnp.nix b/makefu/1systems/pnp.nix
new file mode 100644
index 00000000..1019c4d7
--- /dev/null
+++ b/makefu/1systems/pnp.nix
@@ -0,0 +1,47 @@
+# Edit this configuration file to define what should be installed on
+# your system. Help is available in the configuration.nix(5) man page
+# and in the NixOS manual (accessible by running ‘nixos-help’).
+
+{ config, pkgs, ... }:
+
+{
+ imports =
+ [ # Include the results of the hardware scan.
+ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ../../2configs/makefu/base.nix
+ ../../2configs/makefu/cgit-retiolum.nix
+ ];
+ krebs.build.host = config.krebs.hosts.pnp;
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.version = 2;
+ boot.loader.grub.device = "/dev/vda";
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "ehci_pci" "virtio_pci" "virtio_blk" ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+ hardware.enableAllFirmware = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+# networking.firewall is enabled by default
+ networking.firewall.allowedTCPPorts = [ 80 ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-label/nixos";
+ fsType = "ext4";
+ };
+ krebs.retiolum = {
+ enable = true;
+ hosts = ../../Zhosts;
+ connectTo = [
+ "gum"
+ "pigstarter"
+ "fastpoke"
+ ];
+ };
+
+# $ nix-env -qaP | grep wget
+ environment.systemPackages = with pkgs; [
+ jq
+ ];
+}