summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-03-05 10:59:09 +0100
committermakefu <github@syntax-fehler.de>2016-03-05 10:59:09 +0100
commite8679ae6c0fd33be9c84a671d2ebfae51f5851f0 (patch)
tree9f1bb40c4e522340e164eebadbf2812f3f17e321 /makefu/1systems/omo.nix
parentf3ed026c4749a496c1a5249b55d08081b73e3988 (diff)
ma 1 omo: replace disk2
Diffstat (limited to 'makefu/1systems/omo.nix')
-rw-r--r--makefu/1systems/omo.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/makefu/1systems/omo.nix b/makefu/1systems/omo.nix
index ca0bfd2b..e6a1434a 100644
--- a/makefu/1systems/omo.nix
+++ b/makefu/1systems/omo.nix
@@ -12,11 +12,25 @@ let
# cryptsetup luksAddKey $dev tmpkey
# cryptsetup luksOpen $dev crypt0
# mkfs.xfs /dev/mapper/crypt0 -L crypt0
+
+ # omo Chassis:
+ # __FRONT_
+ # |* d2 |
+ # | |
+ # |* d3 |
+ # | |
+ # |* d0 |
+ # | |
+ # |* d1 |
+ # |* |
+ # | * r0 |
+ # |_______|
cryptDisk0 = byid "ata-ST2000DM001-1CH164_Z240XTT6";
cryptDisk1 = byid "ata-TP02000GB_TPW151006050068";
- cryptDisk2 = byid "ata-WDC_WD20EARS-00MVWB0_WD-WCAZA5548487";
+ # cryptDisk2 = byid "ata-WDC_WD20EARS-00MVWB0_WD-WCAZA5548487";
+ cryptDisk3 = byid "ata-WDC_WD20EARS-00MVWB0_WD-WMAZA1786907";
# all physical disks
- allDisks = [ rootDisk cryptDisk0 cryptDisk1 cryptDisk2 ];
+ allDisks = [ rootDisk cryptDisk0 cryptDisk1 cryptDisk3 ];
in {
imports =
[
@@ -85,7 +99,7 @@ in {
(usbkey "home" homePartition)
(usbkey "crypt0" cryptDisk0)
(usbkey "crypt1" cryptDisk1)
- (usbkey "crypt2" cryptDisk2)
+ (usbkey "crypt2" cryptDisk3)
];
};
loader.grub.device = rootDisk;