summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-07-30 18:43:21 +0200
committermakefu <github@syntax-fehler.de>2016-07-30 18:43:21 +0200
commitd82d6dfb8609fadc8a65c6ff61e8ced2fdbde9ba (patch)
tree2deb7f16ee8cae1cc7ac29ef1b7458ae3d92046c /makefu/1systems/omo.nix
parent75cecd1f2e1ea789d574e4092bc5c2725edf2c00 (diff)
m 1 omo: add wol pkg to systempkgs
Diffstat (limited to 'makefu/1systems/omo.nix')
-rw-r--r--makefu/1systems/omo.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/makefu/1systems/omo.nix b/makefu/1systems/omo.nix
index 699cdb2e..3aa5e943 100644
--- a/makefu/1systems/omo.nix
+++ b/makefu/1systems/omo.nix
@@ -93,7 +93,10 @@ in {
(d: "install -m 755 -d " + (toMapper d) )
[ 0 1 2 "X" ]}
'';
- environment.systemPackages = [ pkgs.mergerfs ];
+ environment.systemPackages = with pkgs;[
+ mergerfs # hard requirement for mount
+ wol # wake up filepimp
+ ];
fileSystems = let
cryptMount = name:
{ "/media/${name}" = { device = "/dev/mapper/${name}"; fsType = "xfs"; };};