summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-22 18:43:38 +0200
committermakefu <github@syntax-fehler.de>2016-08-22 18:43:38 +0200
commit6c487331532019db5c3382edc0b18ab4fe892609 (patch)
tree39780bbddb0e7e52d2539d33b82af2e83e998a77 /makefu/1systems/omo.nix
parent3853da411a98002388ca03c8c730db768b89f91f (diff)
m 1 omo: configure deluge
Diffstat (limited to 'makefu/1systems/omo.nix')
-rw-r--r--makefu/1systems/omo.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/makefu/1systems/omo.nix b/makefu/1systems/omo.nix
index 3aa5e943..96f7be9f 100644
--- a/makefu/1systems/omo.nix
+++ b/makefu/1systems/omo.nix
@@ -50,11 +50,24 @@ in {
#../2configs/share-user-sftp.nix
../2configs/omo-share.nix
../2configs/tinc/retiolum.nix
+ ../2configs/torrent.nix
## as long as pyload is not in nixpkgs:
# docker run -d -v /var/lib/pyload:/opt/pyload/pyload-config -v /media/crypt0/pyload:/opt/pyload/Downloads --name pyload --restart=always -p 8112:8000 -P writl/pyload
];
+ makefu.full-populate = true;
+ makefu.deluge.cfg = {
+ max_active_seeding = 1;
+ stop_seed_ratio = 1;
+ natpmp = true;
+ upnp = true;
+ max_upload_speed = 200;
+ };
+ users.groups.share = {
+ gid = config.krebs.lib.genid "share";
+ members = [ "makefu" "misa" ];
+ };
networking.firewall.trustedInterfaces = [ primaryInterface ];
# udp:137 udp:138 tcp:445 tcp:139 - samba, allowed in local net
# tcp:80 - nginx for sharing files