summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/darth.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-03-16 08:41:13 +0100
committermakefu <github@syntax-fehler.de>2016-03-16 08:41:13 +0100
commit6cb6c96255427580d35fc6b6d545c016f882dcde (patch)
tree9fc62560ef5bfb26a25ef12d0acbb5574d626787 /makefu/1systems/darth.nix
parent3b3b372091b8c5a8015feba2801ba395bf513f2c (diff)
ma 1 darth: configure aux disk
Diffstat (limited to 'makefu/1systems/darth.nix')
-rw-r--r--makefu/1systems/darth.nix28
1 files changed, 25 insertions, 3 deletions
diff --git a/makefu/1systems/darth.nix b/makefu/1systems/darth.nix
index a33744f0..ad3ac4f2 100644
--- a/makefu/1systems/darth.nix
+++ b/makefu/1systems/darth.nix
@@ -1,17 +1,39 @@
{ config, pkgs, lib, ... }:
with config.krebs.lib;
-{
+let
+ byid = dev: "/dev/disk/by-id/" + dev;
+ rootDisk = byid "ata-ADATA_SSD_S599_64GB_10460000000000000039";
+ auxDisk = byid "ata-HGST_HTS721010A9E630_JR10006PH3A02F";
+ dataPartition = auxDisk + "-part1";
+
+ allDisks = [ rootDisk auxDisk ];
+in {
imports = [
+ ../.
../2configs/fs/single-partition-ext4.nix
../2configs/zsh-user.nix
- ../.
+ ../2configs/smart-monitor.nix
];
+ # virtualisation.nova.enableSingleNode = true;
krebs.retiolum.enable = true;
- boot.loader.grub.device = "/dev/disk/by-id/ata-ADATA_SSD_S599_64GB_10460000000000000039";
+ # TODO smartd omo darth gum all-in-one
+ services.smartd.devices = builtins.map (x: { device = x; }) allDisks;
+ zramSwap.enable = true;
+
+ fileSystems."/data" = {
+ device = dataPartition;
+ fsType = "ext4";
+ };
+
+ boot.loader.grub.device = rootDisk;
+
users.users.root.openssh.authorizedKeys.keys = [
config.krebs.users.makefu-omo.pubkey
+ config.krebs.users.makefu-vbob.pubkey
];
+
+ krebs.build.host = config.krebs.hosts.darth;
}