summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/darth.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-04-03 21:42:13 +0200
committermakefu <github@syntax-fehler.de>2016-04-03 21:42:13 +0200
commit4f55e3862c942d8d05591873f587cc767aef3a0d (patch)
tree0833bfaa3b84f08a5dddb33ea0436fa7ae8fe3e6 /makefu/1systems/darth.nix
parent3435e02dadf0a13515a5d387e7a99d5c1a383fe4 (diff)
ma 1 darth: add virtualization
Diffstat (limited to 'makefu/1systems/darth.nix')
-rw-r--r--makefu/1systems/darth.nix20
1 files changed, 16 insertions, 4 deletions
diff --git a/makefu/1systems/darth.nix b/makefu/1systems/darth.nix
index ad3ac4f2..2f2358dd 100644
--- a/makefu/1systems/darth.nix
+++ b/makefu/1systems/darth.nix
@@ -10,15 +10,27 @@ let
allDisks = [ rootDisk auxDisk ];
in {
imports = [
- ../.
- ../2configs/fs/single-partition-ext4.nix
- ../2configs/zsh-user.nix
- ../2configs/smart-monitor.nix
+ ../.
+ ../2configs/fs/single-partition-ext4.nix
+ ../2configs/zsh-user.nix
+ ../2configs/smart-monitor.nix
+ ../2configs/exim-retiolum.nix
+ ../2configs/virtualization.nix
];
+ networking.firewall.allowedUDPPorts = [ 80 655 67 ];
+ networking.firewall.allowedTCPPorts = [ 80 655 ];
+ networking.firewall.checkReversePath = false;
+ #networking.firewall.enable = false;
# virtualisation.nova.enableSingleNode = true;
krebs.retiolum.enable = true;
+ boot.kernelModules = [ "coretemp" "f71882fg" ];
+
+ hardware.enableAllFirmware = true;
+ nixpkgs.config.allowUnfree = true;
+ networking.wireless.enable = true;
+
# TODO smartd omo darth gum all-in-one
services.smartd.devices = builtins.map (x: { device = x; }) allDisks;
zramSwap.enable = true;