summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/cake/hardware-config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-01-13 23:05:12 +0100
committermakefu <github@syntax-fehler.de>2019-01-13 23:05:12 +0100
commit33655bfd89f7ea6f8ab3e3139cd79f4c2d2a0ef6 (patch)
tree20d2c2dd12dff358484a0c3a14d03a4788c8ce37 /makefu/1systems/cake/hardware-config.nix
parentdd22da5e6b4232677a08c24609e9d6517ee2d1b7 (diff)
ma cake.r: remove hack to get wifi working
Diffstat (limited to 'makefu/1systems/cake/hardware-config.nix')
-rw-r--r--makefu/1systems/cake/hardware-config.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/makefu/1systems/cake/hardware-config.nix b/makefu/1systems/cake/hardware-config.nix
new file mode 100644
index 00000000..a81dce4f
--- /dev/null
+++ b/makefu/1systems/cake/hardware-config.nix
@@ -0,0 +1,26 @@
+{ pkgs, lib, ... }:
+{
+ # raspi3
+ boot.loader.grub.enable = false;
+ boot.loader.generic-extlinux-compatible.enable = true;
+ boot.kernelParams = ["cma=32M" "console=ttyS0,115200n8" "console=tty0" ];
+ boot.tmpOnTmpfs = lib.mkForce false;
+ hardware.enableRedistributableFirmware = true;
+
+ ## wifi not working, will be fixed with https://github.com/NixOS/nixpkgs/pull/53747
+ # boot.kernelPackages = pkgs.linuxPackages_latest;
+ boot.kernelPackages = pkgs.linuxPackages;
+
+ networking.wireless.enable = true;
+ # File systems configuration for using the installer's partition layout
+ fileSystems = {
+ "/boot" = {
+ device = "/dev/disk/by-label/NIXOS_BOOT";
+ fsType = "vfat";
+ };
+ "/" = {
+ device = "/dev/disk/by-label/NIXOS_SD";
+ fsType = "ext4";
+ };
+ };
+}