summaryrefslogtreecommitdiffstats
path: root/lib/genid.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-02-05 00:47:55 +0100
committertv <tv@krebsco.de>2023-02-05 01:40:20 +0100
commitf802eaf7847eb7bd1b8a735dac5166fa8999ea06 (patch)
tree757041cf85e88a589b09f7e614d8b9d83500f539 /lib/genid.nix
parent377840226c448fd44f616b77e6057cd414f12480 (diff)
lib.hexchars: init
Diffstat (limited to 'lib/genid.nix')
-rw-r--r--lib/genid.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/genid.nix b/lib/genid.nix
index 0aed1d35..bfa4a9a0 100644
--- a/lib/genid.nix
+++ b/lib/genid.nix
@@ -32,6 +32,5 @@ let out = genid;
hexint = x: hexvals.${toLower x};
# :: attrset char uint4
- hexvals = listToAttrs (imap (i: c: { name = c; value = i - 1; })
- (stringToCharacters "0123456789abcdef"));
+ hexvals = listToAttrs (imap (i: c: { name = c; value = i - 1; }) hexchars);
in out