summaryrefslogtreecommitdiffstats
path: root/lib/eval-source.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-22 23:34:47 +0200
committertv <tv@krebsco.de>2017-07-23 00:29:38 +0200
commit29ae8b026ccd92807e84c1c7c492167f9a97ff3c (patch)
tree3158534e92b248bb3b5104e03f78ba4a9e5ca951 /lib/eval-source.nix
parent297065f98cc6f40cdb3d4eef75f347cf270ce9e4 (diff)
lib.eval-source: sanitize source
Diffstat (limited to 'lib/eval-source.nix')
-rw-r--r--lib/eval-source.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/eval-source.nix b/lib/eval-source.nix
index 468fc92d..ff853185 100644
--- a/lib/eval-source.nix
+++ b/lib/eval-source.nix
@@ -10,6 +10,12 @@ let
};
};
};
+ sanitize = x: getAttr (typeOf x) {
+ set = mapAttrs
+ (const sanitize)
+ (filterAttrs (name: value: name != "_module" && value != null) x);
+ string = x;
+ };
in
# This function's return value can be used as pkgs.populate input.
- _file: source: (eval _file source).config.source
+ _file: source: sanitize (eval _file source).config.source