summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /lib/default.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix62
1 files changed, 0 insertions, 62 deletions
diff --git a/lib/default.nix b/lib/default.nix
deleted file mode 100644
index 164a6a1a..00000000
--- a/lib/default.nix
+++ /dev/null
@@ -1,62 +0,0 @@
-{ lib, pkgs, ... }:
-
-with builtins;
-
-let
- inherit (lib) mapAttrs stringAsChars;
-in
-
-rec {
- git = import ./git.nix {
- lib = lib // {
- inherit addNames;
- };
- inherit pkgs;
- };
-
- addName = name: set:
- set // { inherit name; };
-
- addNames = mapAttrs addName;
-
-
- # "7.4.335" -> "74"
- majmin = with lib; x : concatStrings (take 2 (splitString "." x));
-
-
- concat = xs :
- if xs == []
- then ""
- else head xs + concat (tail xs)
- ;
-
- flip = f : x : y : f y x;
-
- # isSuffixOf :: String -> String -> Bool
- isSuffixOf =
- s : xs :
- let
- sn = stringLength s;
- xsn = stringLength xs;
- in
- xsn >= sn && substring (xsn - sn) sn xs == s ;
-
- removeSuffix =
- s : xs : substring 0 (stringLength xs - stringLength s) xs;
-
- # setMap :: (String -> a -> b) -> Set String a -> [b]
- #setMap = f: xs: map (k : f k (getAttr k xs)) (attrNames xs);
-
- # setToList :: Set k a -> [a]
- #setToList = setMap (_: v: v);
-
- shell-escape =
- let
- isSafeChar = c: match "[-./0-9_a-zA-Z]" c != null;
- in
- stringAsChars (c:
- if isSafeChar c then c
- else if c == "\n" then "'\n'"
- else "\\${c}");
-
-}