summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/mpv-poll
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-03-19 22:01:34 +0100
committerlassulus <lass@aidsballs.de>2016-03-19 22:01:34 +0100
commit429a013aa7d9a737b6bb32bf20c34a0ea469869f (patch)
treef6f126d8d4ccb76cd2849583ea509c064520b816 /lass/5pkgs/mpv-poll
parent369c21ca594cae6d0b15d0a6ea71953d57da7683 (diff)
l 5: add mpv-poll
Diffstat (limited to 'lass/5pkgs/mpv-poll')
-rw-r--r--lass/5pkgs/mpv-poll/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/lass/5pkgs/mpv-poll/default.nix b/lass/5pkgs/mpv-poll/default.nix
new file mode 100644
index 00000000..ee191843
--- /dev/null
+++ b/lass/5pkgs/mpv-poll/default.nix
@@ -0,0 +1,40 @@
+{ pkgs, ... }:
+
+pkgs.writeScriptBin "mpv-poll" ''
+ #! ${pkgs.bash}/bin/bash
+
+ pl=$1
+ hist=''${HISTORY:-"./mpv_history"}
+ mpv_options=''${MPV_OPTIONS:-""}
+
+ lastYT=""
+
+ play_video () {
+ toPlay=$1
+ echo $toPlay >> $hist
+ mpv $mpv_options $toPlay
+ }
+
+ if ! [ -e $hist ]; then
+ touch $hist
+ fi
+
+ while :
+ do
+ if [ -s $pl ]; then
+ toPlay=$(head -1 $pl)
+ sed -i '1d' $pl
+ if $(echo $toPlay | grep -Eq 'https?://(www.)?youtube.com/watch'); then
+ lastYT=$toPlay
+ fi
+ play_video $toPlay
+ else
+ if [ -n "$lastYT" ]; then
+ next=$(yt-next $lastYT)
+ lastYT=$next
+ play_video $next
+ fi
+ sleep 1
+ fi
+ done
+''