summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/firefoxPlugins/ublock.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-26 12:12:50 +0200
committerlassulus <lass@aidsballs.de>2015-09-26 12:12:50 +0200
commit0d806f61d2709f0ff8bf03ee431839035215e689 (patch)
treecb8fda99b540ca280ef5b45319f8d79e786039b0 /lass/5pkgs/firefoxPlugins/ublock.nix
parent895971f21490222e7d4060d5ec1a6bb4395ff595 (diff)
lass: add firefoxPatched + firefoxPlugins
Diffstat (limited to 'lass/5pkgs/firefoxPlugins/ublock.nix')
-rw-r--r--lass/5pkgs/firefoxPlugins/ublock.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/lass/5pkgs/firefoxPlugins/ublock.nix b/lass/5pkgs/firefoxPlugins/ublock.nix
new file mode 100644
index 00000000..29ef250e
--- /dev/null
+++ b/lass/5pkgs/firefoxPlugins/ublock.nix
@@ -0,0 +1,31 @@
+{ fetchgit, stdenv, bash, python, zip }:
+
+stdenv.mkDerivation rec {
+ name = "ublock";
+ id = "{2b10c1c8-a11f-4bad-fe9c-1c11e82cac42}";
+
+ src = fetchgit {
+ url = "https://github.com/chrisaljoudi/uBlock";
+ rev = "a70a50052a7914cbf86d46a725812b98434d8c70";
+ sha256 = "1qfzy79f8x01i33x0m95k833z1jgxjwb8wvlr6fj6id1kxfvzh77";
+ };
+
+ buildInputs = [
+ zip
+ python
+ ];
+
+ patchPhase = ''
+ substituteInPlace "tools/make-firefox.sh" \
+ --replace "/bin/bash" "${bash}/bin/bash"
+ '';
+
+ buildPhase = ''
+ tools/make-firefox.sh all
+ '';
+
+ installPhase = ''
+ mkdir -p $out/
+ cp dist/build/uBlock.firefox.xpi $out/${id}.xpi
+ '';
+}