summaryrefslogtreecommitdiffstats
path: root/lass/2configs/zsh.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-06-26 17:10:25 +0200
committerlassulus <lass@aidsballs.de>2016-06-26 17:10:25 +0200
commit03eaa0320057e4723ccde5525819917312c42105 (patch)
tree3bcb185e1bf086d767bf08b2474c62304a5a4115 /lass/2configs/zsh.nix
parent5608bc02d7728416c7ea083b10cdac91e34f44c5 (diff)
l 2 zsh: fix history size via hack
Diffstat (limited to 'lass/2configs/zsh.nix')
-rw-r--r--lass/2configs/zsh.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/lass/2configs/zsh.nix b/lass/2configs/zsh.nix
index 7299e9ac..b221d767 100644
--- a/lass/2configs/zsh.nix
+++ b/lass/2configs/zsh.nix
@@ -7,9 +7,6 @@
zsh-newuser-install() { :; }
'';
interactiveShellInit = ''
- HISTFILE=~/.histfile
- HISTSIZE=1000000
- SAVEHIST=100000
#unsetopt nomatch
setopt autocd extendedglob
bindkey -e
@@ -92,6 +89,11 @@
esac
'';
promptInit = ''
+ # TODO: figure out why we need to set this here
+ HISTSIZE=900001
+ HISTFILESIZE=$HISTSIZE
+ SAVEHIST=$HISTSIZE
+
autoload -U promptinit
promptinit