summaryrefslogtreecommitdiffstats
path: root/lass/2configs/syncthing.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-01-23 18:20:52 +0100
committerlassulus <lassulus@lassul.us>2021-01-23 18:20:52 +0100
commit9e4d47c5b46a92436d8e71c17a61ab729d4c4133 (patch)
treeba71159c6581efed51e00c908bf58ff7f6c2c8d8 /lass/2configs/syncthing.nix
parent0b5b4b8eab751d0d1d32573c6f69d08a82b4af1e (diff)
l: don't always sync basedir
Diffstat (limited to 'lass/2configs/syncthing.nix')
-rw-r--r--lass/2configs/syncthing.nix13
1 files changed, 1 insertions, 12 deletions
diff --git a/lass/2configs/syncthing.nix b/lass/2configs/syncthing.nix
index 7758b860..d31ce780 100644
--- a/lass/2configs/syncthing.nix
+++ b/lass/2configs/syncthing.nix
@@ -1,6 +1,5 @@
{ config, pkgs, ... }: with import <stockholm/lib>; let
all_peers = filterAttrs (n: v: v.syncthing.id != null) config.krebs.hosts;
- own_peers = filterAttrs (n: v: v.owner.name == "lass") all_peers;
mk_peers = mapAttrs (n: v: { id = v.syncthing.id; });
in {
services.syncthing = {
@@ -11,10 +10,6 @@ in {
key = toString <secrets/syncthing.key>;
cert = toString <secrets/syncthing.cert>;
devices = mk_peers all_peers;
- folders."/home/lass/sync" = {
- devices = attrNames (filterAttrs (n: v: n != "phone") own_peers);
- # ignorePerms = false;
- };
};
};
krebs.iptables.tables.filter.INPUT.rules = [
@@ -26,11 +21,5 @@ in {
${pkgs.coreutils}/bin/chmod a+x /home/lass
'';
- krebs.permown."/home/lass/sync" = {
- file-mode = "u+rw,g+rw";
- owner = "lass";
- group = "syncthing";
- umask = "0002";
- keepGoing = true;
- };
+ boot.kernel.sysctl."fs.inotify.max_user_watches" = 524288;
}