summaryrefslogtreecommitdiffstats
path: root/lass/2configs/realwallpaper.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-09-07 12:26:31 +0200
committerlassulus <git@lassul.us>2023-09-07 13:50:26 +0200
commitf55307fd73af235069744dd5155fda0bc73fe613 (patch)
treef048d7750a50e48493505a08784c96d07d291f89 /lass/2configs/realwallpaper.nix
parent85ae348bf3f53125c8281669a32bf007dc0063be (diff)
lass: migrate away
Diffstat (limited to 'lass/2configs/realwallpaper.nix')
-rw-r--r--lass/2configs/realwallpaper.nix52
1 files changed, 0 insertions, 52 deletions
diff --git a/lass/2configs/realwallpaper.nix b/lass/2configs/realwallpaper.nix
deleted file mode 100644
index 0260b91c..00000000
--- a/lass/2configs/realwallpaper.nix
+++ /dev/null
@@ -1,52 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-let
- hostname = config.krebs.build.host.name;
- inherit (lib)
- nameValuePair
- ;
-
-in {
- krebs.realwallpaper.enable = true;
-
- system.activationScripts.wallpaper-chmod = ''
- ${pkgs.coreutils}/bin/chmod +rx /var/realwallpaper
- '';
- services.nginx.virtualHosts.wallpaper = {
- extraConfig = ''
- if ( $server_addr = "${config.krebs.build.host.nets.internet.ip4.addr}" ) {
- return 403;
- }
- '';
- serverAliases = [
- "wallpaper.r"
- ];
- locations."/".extraConfig = ''
- autoindex on;
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper.png".extraConfig = ''
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper-krebs.png".extraConfig = ''
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper-krebs-stars.png".extraConfig = ''
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper-krebs-stars-berlin.png".extraConfig = ''
- root /var/realwallpaper/;
- '';
- locations."/realwallpaper-video.mp4".extraConfig = ''
- root /var/realwallpaper/archive;
- '';
- };
-
- krebs.iptables = {
- tables = {
- filter.INPUT.rules = [
- { predicate = "-i retiolum -p tcp --dport 80"; target = "ACCEPT"; }
- ];
- };
- };
-}