summaryrefslogtreecommitdiffstats
path: root/lass/2configs/reaktor-coders.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-04-20 23:33:26 +0200
committerlassulus <lassulus@lassul.us>2018-04-20 23:37:15 +0200
commit824c19e81a5696018973be2d692fcd9f07f8ef10 (patch)
tree2b48875dc4105684e695fc3fdf964db4dcbb45ca /lass/2configs/reaktor-coders.nix
parent1d37fba51e4f4fbb7fe7acccc11e2b2ac5dcc5b7 (diff)
l reaktor-coders: add google & blockchain command
Diffstat (limited to 'lass/2configs/reaktor-coders.nix')
-rw-r--r--lass/2configs/reaktor-coders.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/lass/2configs/reaktor-coders.nix b/lass/2configs/reaktor-coders.nix
index 922cd79c..5a39f711 100644
--- a/lass/2configs/reaktor-coders.nix
+++ b/lass/2configs/reaktor-coders.nix
@@ -87,6 +87,19 @@ with import <stockholm/lib>;
exec /run/wrappers/bin/ping -q -c1 "$1" 2>&1 | tail -1
'';
})
+ (buildSimpleReaktorPlugin "google" {
+ pattern = "^!g (?P<args>.*)$$";
+ script = pkgs.writeDash "google" ''
+ exec ${pkgs.ddgr}/bin/ddgr -C -n1 --json "$@" | \
+ ${pkgs.jq}/bin/jq '@text "\(.[0].abstract) \(.[0].url)"'
+ '';
+ })
+ (buildSimpleReaktorPlugin "blockchain" {
+ pattern = ".*[Bb]lockchain.*$$";
+ script = pkgs.writeDash "blockchain" ''
+ exec echo 'DID SOMEBODY SAY BLOCKCHAIN? https://paste.krebsco.de/r99pMoQq/+inline'
+ '';
+ })
];
};
}