summaryrefslogtreecommitdiffstats
path: root/lass/2configs/power-action.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-09-07 12:26:31 +0200
committerlassulus <git@lassul.us>2023-09-07 13:50:26 +0200
commitf55307fd73af235069744dd5155fda0bc73fe613 (patch)
treef048d7750a50e48493505a08784c96d07d291f89 /lass/2configs/power-action.nix
parent85ae348bf3f53125c8281669a32bf007dc0063be (diff)
lass: migrate away
Diffstat (limited to 'lass/2configs/power-action.nix')
-rw-r--r--lass/2configs/power-action.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/lass/2configs/power-action.nix b/lass/2configs/power-action.nix
deleted file mode 100644
index 648ffc78..00000000
--- a/lass/2configs/power-action.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- suspend = pkgs.writeDash "suspend" ''
- ${pkgs.systemd}/bin/systemctl suspend
- '';
-
- speak = text:
- pkgs.writeDash "speak" ''
- ${pkgs.espeak}/bin/espeak -v +whisper -s 110 "${text}"
- '';
-
-in {
- krebs.power-action = {
- enable = true;
- plans.low-battery = {
- upperLimit = 10;
- lowerLimit = 15;
- charging = false;
- action = pkgs.writeDash "warn-low-battery" ''
- ${speak "power level low"}
- '';
- };
- plans.suspend = {
- upperLimit = 10;
- lowerLimit = 0;
- charging = false;
- action = pkgs.writeDash "suspend-wrapper" ''
- /run/wrappers/bin/sudo ${suspend}
- '';
- };
- user = "lass";
- };
-
- users.users.power-action = {
- isNormalUser = true;
- extraGroups = [
- "audio"
- ];
- };
-
- security.sudo.extraConfig = ''
- ${config.krebs.power-action.user} ALL= (root) NOPASSWD: ${suspend}
- '';
-}