summaryrefslogtreecommitdiffstats
path: root/lass/2configs/hass/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2023-07-25 20:39:35 +0200
committertv <tv@krebsco.de>2023-07-25 20:39:35 +0200
commit5d1b0675cf179f863a5b34b67661a953197b6057 (patch)
treedd9c83dff894fd97cee61dd1b2df3eaeecbbd740 /lass/2configs/hass/default.nix
parenta2c9ad05b2e8237b915a100e1e38ca0f3d18526c (diff)
parent8eab63eaa81717391269a61355cb7fb64341fd1a (diff)
Merge remote-tracking branch 'orange/master'
Diffstat (limited to 'lass/2configs/hass/default.nix')
-rw-r--r--lass/2configs/hass/default.nix56
1 files changed, 30 insertions, 26 deletions
diff --git a/lass/2configs/hass/default.nix b/lass/2configs/hass/default.nix
index cc8189f5..1745bbfe 100644
--- a/lass/2configs/hass/default.nix
+++ b/lass/2configs/hass/default.nix
@@ -41,8 +41,7 @@ in {
configWritable = true;
lovelaceConfigWritable = true;
config = let
- tasmota_s20 = name: topic: {
- platform = "mqtt";
+ tasmota = name: topic: {
inherit name;
state_topic = "stat/${topic}/POWER";
command_topic = "cmnd/${topic}/POWER";
@@ -57,7 +56,7 @@ in {
longitude = "13.41489";
elevation = 90;
unit_system = "metric";
- customize = friendly_names;
+ # customize = friendly_names;
};
config = {};
sun.elevation = 66;
@@ -65,36 +64,37 @@ in {
discovery = {};
frontend = {};
http = {};
- mqtt = {
- broker = "localhost";
- port = 1883;
- client_id = "home-assistant";
- username = "gg23";
- password = "gg23-mqtt";
- keepalive = 60;
- protocol = 3.1;
+ # mqtt = {
+ # broker = "localhost";
+ # port = 1883;
+ # client_id = "home-assistant";
+ # username = "gg23";
+ # password = "gg23-mqtt";
+ # keepalive = 60;
+ # protocol = 3.1;
- discovery = true;
- birth_message = {
- topic = "/hass/status";
- payload = "online";
- };
- will_message = {
- topic = "/hass/status";
- payload = "offline";
- };
- };
+ # discovery = true;
+ # birth_message = {
+ # topic = "/hass/status";
+ # payload = "online";
+ # };
+ # will_message = {
+ # topic = "/hass/status";
+ # payload = "offline";
+ # };
+ # };
sensor = [
{
platform = "dwd_weather_warnings";
region_name = "Berlin";
}
];
- switch = [
- (tasmota_s20 "TV" "tv")
- (tasmota_s20 "Drucker Strom" "drucker")
- (tasmota_s20 "Waschmaschine" "wasch")
- (tasmota_s20 "Stereo Anlage" "stereo")
+ mqtt.switch = [
+ (tasmota "TV" "tv")
+ (tasmota "Drucker Strom" "drucker")
+ (tasmota "Waschmaschine" "wasch")
+ (tasmota "Stereo Anlage" "stereo")
+ (tasmota "Wohnzimmer Lampe" "wohn_lampe")
];
mobile_app = {};
weather = [
@@ -106,6 +106,10 @@ in {
system_health = {};
history = {};
shopping_list = {};
+ media_player = {
+ platform = "snapcast";
+ host = "127.0.0.1";
+ };
};
};