summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-06-07 03:14:21 +0200
committertv <tv@krebsco.de>2016-06-07 22:38:38 +0200
commit4a34b27c1c6c3fea2b336c0316c597d74460b428 (patch)
tree97b718fe06acba0f298a78207ed9a5cbfd542b1e /lass/2configs/git.nix
parent6fcc35afb0003f0885994b3c09e401f3178d7a08 (diff)
krebs.git.cgit: make `cache-root` configurable
... along with all the other stuff :)
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix22
1 files changed, 13 insertions, 9 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index aac3f6e0..c0affe98 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -7,8 +7,12 @@ let
out = {
krebs.git = {
enable = true;
- root-title = "public repositories at ${config.krebs.build.host.name}";
- root-desc = "keep calm and engage";
+ cgit = {
+ settings = {
+ root-title = "public repositories at ${config.krebs.build.host.name}";
+ root-desc = "keep calm and engage";
+ };
+ };
repos = mapAttrs (_: s: removeAttrs s ["collaborators"]) repos;
rules = rules;
};
@@ -27,7 +31,7 @@ let
public-repos = mapAttrs make-public-repo {
painload = {};
stockholm = {
- desc = "take all the computers hostage, they'll love you!";
+ cgit.desc = "take all the computers hostage, they'll love you!";
};
wai-middleware-time = {};
web-routes-wai-custom = {};
@@ -52,8 +56,8 @@ let
import <secrets/repos.nix> { inherit config lib pkgs; }
);
- make-public-repo = name: { desc ? null, ... }: {
- inherit name desc;
+ make-public-repo = name: { cgit ? {}, ... }: {
+ inherit cgit name;
public = true;
hooks = {
post-receive = pkgs.git-hooks.irc-announce {
@@ -66,13 +70,13 @@ let
};
};
- make-public-repo-silent = name: { desc ? null, ... }: {
- inherit name desc;
+ make-public-repo-silent = name: { cgit ? {}, ... }: {
+ inherit cgit name;
public = true;
};
- make-restricted-repo = name: { collaborators ? [], desc ? null, ... }: {
- inherit name collaborators desc;
+ make-restricted-repo = name: { collaborators ? [], ... }: {
+ inherit collaborators name;
public = false;
};