summaryrefslogtreecommitdiffstats
path: root/lass/2configs/exim-smarthost.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-04-12 15:16:40 +0200
committerlassulus <lass@aidsballs.de>2016-04-12 15:16:40 +0200
commit6da220c50848843a4d6e546a8639d0a573bf210b (patch)
treee127d25a176fcc7651a801ebf05ec3650b0e2439 /lass/2configs/exim-smarthost.nix
parent4f04085d5239e2c688a370706f9007edd0a0d5bb (diff)
l 2: add exim-smarthost configuration
Diffstat (limited to 'lass/2configs/exim-smarthost.nix')
-rw-r--r--lass/2configs/exim-smarthost.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/lass/2configs/exim-smarthost.nix b/lass/2configs/exim-smarthost.nix
new file mode 100644
index 00000000..7f838a31
--- /dev/null
+++ b/lass/2configs/exim-smarthost.nix
@@ -0,0 +1,49 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ krebs.exim-smarthost = {
+ enable = true;
+ #dkim = [
+ # { domain = "lassul.us"; }
+ #];
+ sender_domains = [
+ "lassul.us"
+ ];
+ relay_from_hosts = map (host: host.nets.retiolum.ip4.addr) [
+ config.krebs.hosts.mors
+ config.krebs.hosts.uriel
+ config.krebs.hosts.helios
+ ];
+ internet-aliases = with config.krebs.users; [
+ { from = "postmaster@lassul.us"; to = lass.mail; } # RFC 822
+ { from = "lass@lassul.us"; to = lass.mail; }
+ { from = "lassulus@lassul.us"; to = lass.mail; }
+ { from = "test@lassul.us"; to = lass.mail; }
+ ];
+ system-aliases = [
+ { from = "mailer-daemon"; to = "postmaster"; }
+ { from = "postmaster"; to = "root"; }
+ { from = "nobody"; to = "root"; }
+ { from = "hostmaster"; to = "root"; }
+ { from = "usenet"; to = "root"; }
+ { from = "news"; to = "root"; }
+ { from = "webmaster"; to = "root"; }
+ { from = "www"; to = "root"; }
+ { from = "ftp"; to = "root"; }
+ { from = "abuse"; to = "root"; }
+ { from = "noc"; to = "root"; }
+ { from = "security"; to = "root"; }
+ { from = "root"; to = "lass"; }
+ ];
+ };
+
+ krebs.setuid.sendmail = {
+ filename = "${pkgs.exim}/bin/exim";
+ mode = "4111";
+ };
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport smtp"; target = "ACCEPT"; }
+ ];
+}