summaryrefslogtreecommitdiffstats
path: root/lass/1systems/xerxes/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-07-11 16:09:14 +0200
committerlassulus <lassulus@lassul.us>2019-07-11 16:09:14 +0200
commit13d8d9f7d340a64cd69957854c628dc4ca0876e6 (patch)
tree1cdc867fc147bdabedefb2dfcdcaa7e2b98cd914 /lass/1systems/xerxes/physical.nix
parent03aea512d8be3b38be78ab99c6f0dd9400e71d97 (diff)
Revert "l: rip xerxes"
This reverts commit 4e04b2ac99885f2d953487b506d37c5519794754.
Diffstat (limited to 'lass/1systems/xerxes/physical.nix')
-rw-r--r--lass/1systems/xerxes/physical.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/lass/1systems/xerxes/physical.nix b/lass/1systems/xerxes/physical.nix
new file mode 100644
index 00000000..17caccfe
--- /dev/null
+++ b/lass/1systems/xerxes/physical.nix
@@ -0,0 +1,29 @@
+{
+ imports = [
+ ./config.nix
+ <stockholm/lass/2configs/hw/gpd-pocket.nix>
+ <stockholm/lass/2configs/boot/stock-x220.nix>
+ ];
+ services.udev.extraRules = ''
+ SUBSYSTEM=="net", ATTR{address}=="b0:f1:ec:9f:5c:78", NAME="wl0"
+ '';
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/d227d88f-bd24-4e8a-aa14-9e966b471437";
+ fsType = "btrfs";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/16C8-D053";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" = {
+ device = "/dev/disk/by-uuid/1ec4193b-7f41-490d-8782-7677d437b358";
+ fsType = "btrfs";
+ };
+
+ boot.initrd.luks.devices = [ { name = "luksroot"; device = "/dev/disk/by-uuid/d17f19a3-dcba-456d-b5da-e45cc15dc9c8"; } ];
+
+ networking.wireless.enable = true;
+}