summaryrefslogtreecommitdiffstats
path: root/lass/1systems/xerxes/icarus/physical.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-07-16 19:06:14 +0200
committerjeschli <jeschli@gmail.com>2019-07-16 19:06:14 +0200
commitcd4f0290ed091cdae9b5d8526f4387b54e2c42dc (patch)
tree1db65f278382130f52da18aaafbc31d7d8e52376 /lass/1systems/xerxes/icarus/physical.nix
parentecb6c5fe8784de4aeceef437368cb501e1d659ce (diff)
parent3f0435e89cbdccf8ad8ab351cc3eab349c427e60 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'lass/1systems/xerxes/icarus/physical.nix')
-rw-r--r--lass/1systems/xerxes/icarus/physical.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/lass/1systems/xerxes/icarus/physical.nix b/lass/1systems/xerxes/icarus/physical.nix
new file mode 100644
index 00000000..e9e09bc0
--- /dev/null
+++ b/lass/1systems/xerxes/icarus/physical.nix
@@ -0,0 +1,25 @@
+{
+ imports = [
+ ./config.nix
+ <stockholm/lass/2configs/hw/x220.nix>
+ <stockholm/lass/2configs/boot/coreboot.nix>
+ ];
+
+ fileSystems = {
+ "/bku" = {
+ device = "/dev/mapper/pool-bku";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ };
+
+ services.udev.extraRules = ''
+ SUBSYSTEM=="net", ATTR{address}=="00:24:d7:f0:a0:0c", NAME="wl0"
+ SUBSYSTEM=="net", ATTR{address}=="f0:de:f1:71:cb:35", NAME="et0"
+ '';
+
+ services.thinkfan.enable = true;
+ services.tlp.extraConfig = ''
+ START_CHARGE_THRESH_BAT0=80
+ '';
+}