summaryrefslogtreecommitdiffstats
path: root/lass/1systems/uriel/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2018-05-12 15:51:24 +0200
committerlassulus <lassulus@lassul.us>2018-05-12 15:51:24 +0200
commit0c0d527bec3a6a3d6435203253edb2ef27f9655b (patch)
treec557aa36ab0eb475bab5c78c046caea3610f84bf /lass/1systems/uriel/physical.nix
parent079396f9e11573228bd6cf498f161c49660a7549 (diff)
l: hw config into physical.nix
Diffstat (limited to 'lass/1systems/uriel/physical.nix')
-rw-r--r--lass/1systems/uriel/physical.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/lass/1systems/uriel/physical.nix b/lass/1systems/uriel/physical.nix
new file mode 100644
index 00000000..9ac3468a
--- /dev/null
+++ b/lass/1systems/uriel/physical.nix
@@ -0,0 +1,59 @@
+{
+ imports = [
+ ./config.nix
+ ];
+
+ hardware.enableAllFirmware = true;
+ boot = {
+ #kernelParams = [
+ # "acpi.brightness_switch_enabled=0"
+ #];
+ #loader.grub.enable = true;
+ #loader.grub.version = 2;
+ #loader.grub.device = "/dev/sda";
+
+ loader.systemd-boot.enable = true;
+ loader.timeout = 5;
+
+ initrd.luks.devices = [ { name = "luksroot"; device = "/dev/sda2"; } ];
+ initrd.luks.cryptoModules = [ "aes" "sha512" "sha1" "xts" ];
+ initrd.availableKernelModules = [ "xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
+ #kernelModules = [ "kvm-intel" "msr" ];
+ kernelModules = [ "msr" ];
+ };
+ fileSystems = {
+ "/" = {
+ device = "/dev/pool/root";
+ fsType = "ext4";
+ };
+
+ "/bku" = {
+ device = "/dev/pool/bku";
+ fsType = "ext4";
+ };
+
+ "/boot" = {
+ device = "/dev/sda1";
+ };
+ "/tmp" = {
+ device = "tmpfs";
+ fsType = "tmpfs";
+ options = ["nosuid" "nodev" "noatime"];
+ };
+ };
+
+ services.udev.extraRules = ''
+ SUBSYSTEM=="net", ATTR{address}=="64:27:37:7d:d8:ae", NAME="wl0"
+ SUBSYSTEM=="net", ATTR{address}=="f0:de:f1:b8:c8:2e", NAME="et0"
+ '';
+
+ services.xserver.synaptics = {
+ enable = true;
+ twoFingerScroll = true;
+ accelFactor = "0.035";
+ additionalOptions = ''
+ Option "FingerHigh" "60"
+ Option "FingerLow" "60"
+ '';
+ };
+}