summaryrefslogtreecommitdiffstats
path: root/lass/1systems/shodan/config.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-07-23 21:10:50 +0200
committerlassulus <lassulus@lassul.us>2017-07-23 21:39:31 +0200
commit8d34735c3099648fb3444d218c78fb3fb7612c46 (patch)
tree5d47da9bdb11a35372cc61ae257b726101f84775 /lass/1systems/shodan/config.nix
parent1bf9e1e1eea95ea9efeb72a48e19a6df11881a7f (diff)
lass: cleanup
Diffstat (limited to 'lass/1systems/shodan/config.nix')
-rw-r--r--lass/1systems/shodan/config.nix57
1 files changed, 4 insertions, 53 deletions
diff --git a/lass/1systems/shodan/config.nix b/lass/1systems/shodan/config.nix
index a68471aa..00ea8267 100644
--- a/lass/1systems/shodan/config.nix
+++ b/lass/1systems/shodan/config.nix
@@ -4,8 +4,11 @@ with import <stockholm/lib>;
{
imports = [
<stockholm/lass>
+ #TODO reinstall with correct layout and use lass/hw/x220
+ <stockholm/krebs/2configs/hw/x220.nix>
+
+ <stockholm/lass/2configs/mouse.nix>
<stockholm/lass/2configs/retiolum.nix>
- <stockholm/lass/2configs/hw/tp-x220.nix>
<stockholm/lass/2configs/baseX.nix>
<stockholm/lass/2configs/git.nix>
<stockholm/lass/2configs/exim-retiolum.nix>
@@ -14,58 +17,6 @@ with import <stockholm/lib>;
<stockholm/lass/2configs/fetchWallpaper.nix>
<stockholm/lass/2configs/backups.nix>
<stockholm/lass/2configs/wine.nix>
- #{
- # users.extraUsers = {
- # root = {
- # openssh.authorizedKeys.keys = map readFile [
- # ../../krebs/Zpubkeys/uriel.ssh.pub
- # ];
- # };
- # };
- #}
- {
- users.users.sokratess = {
- uid = genid "sokratess";
- home = "/home/sokratess";
- group = "users";
- createHome = true;
- extraGroups = [
- "audio"
- "networkmanager"
- ];
- useDefaultShell = true;
- password = "aidsballs";
- };
- krebs.per-user.sokratess.packages = [
- pkgs.firefox
- pkgs.python27Packages.virtualenv
- pkgs.python27Packages.ipython
- pkgs.python27Packages.python
- ];
- }
- {
- krebs.monit = let
- echoToIrc = msg:
- pkgs.writeDash "echo_irc" ''
- set -euf
- export LOGNAME=prism-alarm
- ${pkgs.irc-announce}/bin/irc-announce \
- ni.r 6667 ${config.networking.hostName}-alarm \#noise "${msg}" >/dev/null
- '';
- in {
- enable = true;
- http.enable = true;
- alarms = {
- hfos = {
- test = "${pkgs.curl}/bin/curl -sf --insecure 'https://hfos.hackerfleet.de'";
- alarm = echoToIrc "test hfos failed";
- };
- };
- };
- krebs.iptables.tables.filter.INPUT.rules = [
- { predicate = "-p tcp -i retiolum --dport 9093"; target = "ACCEPT"; }
- ];
- }
];
krebs.build.host = config.krebs.hosts.shodan;