summaryrefslogtreecommitdiffstats
path: root/lass/1systems/morpheus/config.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2020-06-13 12:20:19 +0200
committermakefu <github@syntax-fehler.de>2020-06-13 12:20:19 +0200
commit8cda0c6a82068348a995f4d814234ae26cd1337e (patch)
tree6ae68565a4f4652d987459aa60efc8007b6d4bb4 /lass/1systems/morpheus/config.nix
parent8dc4c3d153f4f6536815dbb122bf5465ed3a800a (diff)
parent47ea2f1d631516451b4eb920cc799cfd8f006ad6 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'lass/1systems/morpheus/config.nix')
-rw-r--r--lass/1systems/morpheus/config.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/lass/1systems/morpheus/config.nix b/lass/1systems/morpheus/config.nix
new file mode 100644
index 00000000..c3a8ea6c
--- /dev/null
+++ b/lass/1systems/morpheus/config.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+{
+ imports = [
+ <stockholm/lass>
+ <stockholm/lass/2configs/retiolum.nix>
+ ];
+
+ krebs.build.host = config.krebs.hosts.morpheus;
+
+ networking.wireless.enable = false;
+ networking.networkmanager.enable = true;
+
+ services.logind.lidSwitch = "ignore";
+ services.logind.lidSwitchDocked = "ignore";
+
+ environment.systemPackages = with pkgs; [
+ gitAndTools.hub
+ nix-review
+ firefox
+ ];
+
+ services.openssh.forwardX11 = true;
+ programs.x2goserver.enable = true;
+}