summaryrefslogtreecommitdiffstats
path: root/lass/1systems/hilum/physical.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2019-09-22 11:40:48 +0200
committerlassulus <lassulus@lassul.us>2019-09-22 11:40:48 +0200
commita72d092a118dbe13b9da609d43b01d06b9f7ab54 (patch)
treea56f585de0f48777199f336e631c10571078ee0d /lass/1systems/hilum/physical.nix
parent8cb8de31d0a3b1bcb6eb91d0c23740b8c14d29bd (diff)
l: add hilum.r
Diffstat (limited to 'lass/1systems/hilum/physical.nix')
-rw-r--r--lass/1systems/hilum/physical.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/lass/1systems/hilum/physical.nix b/lass/1systems/hilum/physical.nix
new file mode 100644
index 00000000..f8bab57d
--- /dev/null
+++ b/lass/1systems/hilum/physical.nix
@@ -0,0 +1,35 @@
+{ lib, pkgs, ... }:
+
+{
+ imports = [
+ ./config.nix
+ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "xhci_pci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ "dm-snapshot" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ boot.loader.grub.enable = true;
+ boot.loader.grub.efiSupport = true;
+ boot.loader.grub.device = "/dev/disk/by-id/usb-General_USB_Flash_Disk_0374116060006128-0:0";
+ boot.loader.grub.efiInstallAsRemovable = true;
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/6db29cdd-ff64-496d-b541-5f1616665dc2";
+ fsType = "ext4";
+ };
+
+ boot.initrd.luks.devices."usb_nix".device = "/dev/disk/by-uuid/3c8ab3af-57fb-4564-9e27-b2766404f5d4";
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/2B9E-5131";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 4;
+ powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}